Home EDITOR’S PICKS WordPress Classic Editor Plugin Not Working after Update to WordPress 5.5

WordPress Classic Editor Plugin Not Working after Update to WordPress 5.5

by Cengiz Kuskaya

Problem Description

After Update to WordPress Version 5.5, Classic Editor Plugin can stop working and you might not able to edit your posts. Classic Editor buttons like Add Media, Add From, Link, b-quote and Post Title box can disappear or get unresponsive. Furthermore all of your custom Theme related Accordions (collapsible boxes) or Sections can be unresponsive in “Edit Post Admin UI“.

Classic Editor buttons disappeared.

Solution

This problem occurs because of an incompatiblity or mismatch between the custom or 3rd party Theme Author’s “Custom Post Format Admin UI” Plugin or Code, “WordPress Classic Editor” Plugin and “WordPress Version 5.5”. Most of the custom Theme’s accesses or changes the Post Admin UI and the Classic Editor too.

Note !
This problem doesn’t occur if you use one of the built-in WordPress Themes like the “Twenty Sixteen” or “Twenty Twenty“.

1. To fix this problem you can basically disable your custom Theme’s “Custom Post Format Admin UI” Plugin. This will allow you to use “WordPress Classic Editor” Plugin properly and all Editing options will appear again like in the screenshot below.

Deactivate Custom Post Format Admin UI Plugin.

After deactivating the “Custom Post Format Admin UI” Plugin or Code, Classic Editor buttons appeares again.

2. If your Theme doesn’t have a Plugin for the Custom Post Format in the Admin UI you can request for help from your Theme Author.

3. What you can also do is, disable your Theme’s required Plugins one by one to figure out if the “Custom Post Format Admin UI” code is inside another Plugin. This is also possible. It’s worth a try.

4. If this doesn’t help too, this would mean that your “Custom Post Format Admin UI” code is embedded somewhere else inside the \wp-content folder. If you aren’t a Developer it might be difficult for your to pick it up from there and edit. Under these circumstances I would recommend to revert back your Worpdress Version to an older Version which works best for you.

Good luck !